« Back to all recent discussions

Firmware upgrade!

elcapitoelcapito Posts: 12  Junior Member
edited December 2017 in Questions
First I receive this:

I select"Start", an after some time I get this:

I select "Confirm", and I get this again:

This goes on and on without anything more happening. I tried to restart the "main" Multy X (now in bridge mode" but the cycle repeats itself. The Wi Fi is working well but............anyone with a good solution?


Best Answer


  • ENDLESSENDLESS Posts: 39  Junior Member
    Hi elcapito,
    May I know your Multy X app version and the upgrade steps?
    About this problem: Are you upgrade the latest app version first? After that, change to bridge mode, then upgrade to the latest FW of Multy X?
  • elcapitoelcapito Posts: 12  Junior Member
    Endless! Thanks for taking time to help!
    As you can see I have been contacted by Zyxel to rectify my problem. I will wait for their solution, but in the unlikely event of them coming short of a fix, I will try your suggestion!

    Thanks again!
  • elcapitoelcapito Posts: 12  Junior Member
    Problem is now solved! I already had the latest issue. The prompt to upgrade is now removed!
Sign In or Register to comment.