« Back to all recent discussions

NAS326 firmware upgrade

Cooper_CCooper_C Posts: 13  Junior Member
edited December 2017 in Discussions
Upgraded NAS326 firmware to v5.21.  Connecting to the GUI via box IP address returns a 404 error.  Using the NAS Starter Utility, able to reach the web page, but none of the icons show, and the icons at the top of the page do not function.  Research via Google has returned no results.  Has anybody else experienced this problem and have a solution?  Contacted Zyxel and waiting on a reply.

#NAS_December
«1

Comments

  • MihawkMihawk Posts: 103  Warrior Member
    @Cooper_C
    Make sure the NAS326 recevied the correct IP address and clear browser history and try again.
    If the problem still exist, that you might need to reset the password and IP with 1 beep and try again, if no help, might reset the device.
  • Cooper_CCooper_C Posts: 13  Junior Member
    I've tried multiple browsers after clearing the cache, cookies, etc.  I have also done the one beep reset and the three beep reset and yet the browsers continue to receive the 404 error code.  Getting access to the management web page was hit and miss on the old firmware.  Unable to ssh or telnet to the device.  The file shares and access to them are not a problem.
  • RoryRory Posts: 120  Warrior Member
    @Cooper_C

    What's the result if use myZyXEL to find your NAS?
    https://findme.zyxel.com/

    What's the status of system LED?



  • Cooper_CCooper_C Posts: 13  Junior Member
    @Rory

    I have a solid white system light.  No errors noted.
  • Cooper_CCooper_C Posts: 13  Junior Member
    @Rory

    myZyXEL can locate the device.

  • Zyxel_BrianZyxel_Brian Posts: 41  Zyxel Moderator
    @Cooper_C
    We have contacted you via private message.
    Please check you message box.
    Thanks.

    BRs, Brian.
  • Cooper_CCooper_C Posts: 13  Junior Member
    Zyxel is going to RMA the unit.  Thanks to all that responded.
  • Cooper_CCooper_C Posts: 13  Junior Member
    Strike the RMA.  Zyxel sent firmware v5.20.  Installed and now have complete access to the box.
  • PeppinoPeppino Posts: 6  Junior Member
    I ran into the same issue. Can you please share that firmware?
  • Fredzoul1Fredzoul1 Posts: 97  Warrior Member
    edited December 2017
    You can directly download it in this FTP, because old version are always available :-)
    ftp://ftp.zyxel.fr/ftp_download/NAS326/firmware/
  • PeppinoPeppino Posts: 6  Junior Member
    oooh, I didn't pay attention, that he received an older version... I thought he got a beta fw or something. Unfortunately mine will not allow a downgrade.
  • MijzelfMijzelf Posts: 1,243  Heroic Warrior Member
    Yes it will, but you'll have to prepare it. Enable ssh, login as root, and execute
    echo 1 >/firmware/mnt/info/revision

    Now you can downgrade.

  • Cooper_CCooper_C Posts: 13  Junior Member
    I found all the firmware revision here:

    ftp://ftp.zyxel.com/NAS326/firmware/

    Downgrading was pretty straight forward.  Format a USB stick for FAT32, copy all the files from the zip file to the stick.  Power down the box and insert the stick in one of the back USB ports. Boot up the box and the firmware gets loaded.  At the above link, there is a instructional pdf.  The issue I'm having now is that admin password change isn't sticking.  The web page offers to let you change the password and is supposed to redirect to the login page, which it does not.  It just hangs.  I ssh into the box and used passwd admin to change password.  But that password seems to work only when SSHing into the box.  Not sure what the root password is.


  • Cooper_CCooper_C Posts: 13  Junior Member
    Figured out the root password and changed via the terminal. Tried adding a user via GUI, but just like changing the admin password, the add user page just hangs.
  • NathanSNathanS Posts: 2  Junior Member
    Ran into something similar. I flashed 5.21 on. Web is broke, but I can ssh into the box. lsof shows http is not running, nor is anyone listening on 80/443.  I could roll back but the ftp site shows six different versions of 5.20. All I really need to do is enable/configure printing, but doing so via ssh isn't documented.
Sign In or Register to comment.