« Back to all recent discussions

NSA325 reboots arbitrarily

geieraffegeieraffe Posts: 5  Junior Member
edited December 2017 in Questions
I have a serious problem with my NSA325:

I used it for "network storage", so I haven't noticed if it occured since ever.

The NSA325 reboots for no reason. Sometimes after 3 hours, sometimes after 13 hours, but sure at least once a day. The big problem now is I have more than 1TB data on it and does not finish resync before the reboot.
I realy have no idea why, so I can't give any further information. Protocol is clear after reboot.
Tryed another power adapter these days ...same issue.
Tryed it with removed HDDs ...same issue.

Please help! :)

#NAS_December
Tagged:

Answers

  • MijzelfMijzelf Posts: 572  Heroic Warrior Member
    Have you already tried a factory reset? The automatic shutdown based on time is known to be buggy.
  • geieraffegeieraffe Posts: 5  Junior Member
    edited December 2017
    What's the best way to do a factory reset?
    Can I do it on the web interface (havent found something there).
    If I have to use Telnet, I need some how to :)


    Edit: Ah sorry ....just found the reset button on the back of the NAS  o:)
  • Fredzoul1Fredzoul1 Posts: 97  Warrior Member
    edited December 2017
    @geieraffe,
    Here in the forum the procedure in image :-)
    https://homeforum.zyxel.com/discussion/comment/1021#Comment_1021
    Make the reset with 2 bips to clean all setting et restart with a new conf.
  • geieraffegeieraffe Posts: 5  Junior Member
    Thanks so far.
    I nearly thougt my problem is solved with the factory reset.
    But I just checked it:
    Resync was at 18% (64% when I checked last) and the protocol was clear with a new boot 7h after I made the factory reset.

    So factory reset didn't change anything for me :(

    More proposals what it could be/what I could do?
  • RoryRory Posts: 118  Warrior Member
    @geieraffe

    Did you set up power on/off scheduling for your NSA325?
    If yes, then remove it.
    And you can monitor the temperature of NSA325,
    maybe high temperature cause device auto reboot.
  • geieraffegeieraffe Posts: 5  Junior Member
    @Rory

    No, haven't touched the power scheduling after the factory reset.

    Temperature should be ok, it's on 40°C constantly.
  • MijzelfMijzelf Posts: 572  Heroic Warrior Member
    More proposals what it could be/what I could do?

    There are 2 possibilities. It's software initiated or it's hardware. You can test if te reboot is software initiated. In that case it will do a 'proper' shutdown, executing all shutdown scripts.

    If you install Tweaks, you can add a command to the cron daemon:
    @shutdown date >>/i-data/md0/admin/shutdown.log
    
    This will add date&time in a logfile in the admin share. Shutdown it once manually, to see if it works, and than wait for a spontaneous reboot. Is your mains solid? Could it be a microdrop?
  • geieraffegeieraffe Posts: 5  Junior Member
    @Mijzelf
    Thanks, I'll try this the next days.
    But I guess it's a hardware problem. It does not 'sound' like a proper shutdown.

    I thought myself about some kind of micro drop, but I'm in southwest germany and no other device ever had a problem.
    As mentioned I already tryed an other power adapter with no success.

    So it seems it's time for a new NAS!?
    If I stay with one from Zyxel, can I just put my HDDs from the old one to the new one (RAID1)?
    And what NAS would be a good option? I will use it as a data grave most of the time.
    A Zyxel NAS326?
  • MijzelfMijzelf Posts: 572  Heroic Warrior Member
    If I stay with one from Zyxel, can I just put my HDDs from the old one to the new one (RAID1)?
    No. The current NASses (firmware 5+) have another disk layout, and the NAS won't accept a '325 disk as internal disk.
    It is possible to (manually) convert a RAID1 array inside the new NAS, but that boils down to creating a volume on one of the disks, copy everything over, and add the remaining disk to the array.
    And what NAS would be a good option?
    If you want a ZyXEL you have 3 possibilities. NAS326, NAS520 and NAS542. Two dual disk and one 4 disk box. 
    If you want to be able to put Debian or something like that on the NAS, go for the '326. it has a Marvell CPU which already is, or is about to be supported by the vanilla kernel. The 5xx has a less common CPU, which means it is not, and maybe will never be supported.
    The 520 is a bit more powerful than the 326. It has a dual core CPU, while the 326 hasn't. If your 325 now is sufficient, you don't need that extra power.
    The 542 is identical to the 520, apart from it's 4 disk slots.

  • DennerDenner Posts: 3  Junior Member
    Die 325 V2 hat einen Designfehler. Da brennt mit der Zeit irgendwo was durch, war bei meiner auch. Platten raus, Daten retten und eine andere NAS besorgen.

    Kannst nach googlen, wir sind nicht die einzigen, die von dem Hardwarefehler betroffen sind.l
Sign In or Register to comment.