« Back to all recent discussions

NSA542 HDD failure - issues with repair/resync

Hello,

I had a disk failure in the NSA542. The NAS ran ok for a few years with 4 x 3TB Seagate drives, but last week one of the drives failed. I had a single 8TB volume on RAID5. Unfortunately, I couldn't find the exact same type of drive, but I've bought a 3TB Toshiba with the same SATA speed and same rpm. I installed in the NAS and started the repair, but the problem is, after it runs for hours and gets to above 60%, all of a sudden it stops and the volume is gone and all I can see is the drives (all showing up as green). If I reboot it, it goes through the same process, repair, 60%, everything gone. And so on.

I managed to copy all the data on some external drives I have, but is there any way to just destroy all the volume configuration it has and start with a fresh config? The UI doesn't allow for this, it just goes through the endless resync/repair process. I don't care about the data at this point, I just want it ready for a new volume configuration. I was wondering if it's possible through the command line to just clear all the volume information.

Thanks,

Comments

  • MijzelfMijzelf Posts: 1,358  Paragon Member
    I think wiping the partition tables should do. Login as root over ssh, and execute

    dd if=/dev/zero of=/dev/sda bs=1M count=1
    dd if=/dev/zero of=/dev/sdb bs=1M count=1
    dd if=/dev/zero of=/dev/sdc bs=1M count=1
    dd if=/dev/zero of=/dev/sdd bs=1M count=1
    reboot

    This will wipe the first megabyte of each disk. I assume you don't have an usb disk/stick connected, and no sd cart, else you might wipe the wrong device.



Sign In or Register to comment.