« Back to all recent discussions

NAS 542 transfer speed

Fabione82Fabione82 Posts: 3  Junior Member
Hello everyone, I have a problem with my NAS 542. For some time I have seen that the transfer speed of files from the PC to the NAS is very low (1-3 MB / s). Both the PC and the NAS are connected with cat.6 cables to the Gigabit switch. What could be the problem? Thank you and good day.

Answers

  • MijzelfMijzelf Posts: 1,358  Paragon Member
    There can be several reasons.
    1) You are actually using wifi. I have seen on W10 boxes that wifi got a higher priority, when it has the same network segment as cabled.
    2) The disk is (almost) full. The throughput of ext4 collapses when the disk is almost full, especially on mechanical disks.
    3) The disk is dying. Check the smart values.
    4) You are transferring a lot of small files. Than the random access time of mechanical disk have a huge impact on throughput.
    5) An aggressive virus scanner.
    6) The NAS is busy with other things. Have a look at the tasks list, you can find somewhere in the webinterface.
  • jenniferjamesjenniferjames Posts: 2  Junior Member
    edited November 6
    Link speeds between computers and network devices is all throttled by the slowest speed in the link chain. 
  • Fabione82Fabione82 Posts: 3  Junior Member
    Scrivi il tuo cHi Mijzelf and jenniferjames, thanks for the replies.
    I noticed that the problem of low data transfer speed I have it only when I copy data from PC to NAS while from NAS to PC it is fast (70-90 MB/s)

    Mijzelf I checked what you wrote to me:
    1) There is no wi-fi
    2) the disks have at least 30% free space
    3) I have 3 discs: 2 discs have 2 years of life and 1 disc has 2 months of life. The system tells me the discs are fine.
    4) The files are at least 4Gb
    5) I tried to disable the antivirus (Avast) but nothing has changed
    6) The NAS is used only as external storage and I have access only from my pc

    jenniferjames:
    how do i check if there is a link that slows me down the whole chain?
  • MijzelfMijzelf Posts: 1,358  Paragon Member
    Have you tried another cable, switch, switch port? If you have shell access to the NAS you could execute 'ifconfig'  to see if you have a lot of network errors.
  • Fabione82Fabione82 Posts: 3  Junior Member
    I tried to change the cables (always cat6) and put back the 5 port switch I had before (now I have an 8 port one) but nothing has changed. I don't know how to access the NAS shell, I'm not very practical
  • lodiabailodiabai Posts: 118  Warrior Member
    You can download "putty" or "teraterm" to access the shell by using SSH.
    To access the NAS shell it required your NAS IP address.
Sign In or Register to comment.