« Back to all recent discussions

VMG3925-B10C Wifi Issues

PhantomR1982PhantomR1982 Posts: 2  Junior Member
Hi There,

Im quite a knowledgable person when it comes to tech & routers however i dont know everything and i can sometimes spot bugs in a variety of ways these days however let me explain the issues im having.

I've had Two Zyxel Branded Routers now as most ISP Providers over here in the United Kingdom have one for Standard DSL (ADSL2+) Up to 24mb connections normally Around 10-12mb and Then a Secondary Router when you upgrade to a fibre package (VDSL2) which is 40-80mbps down and 10-20mbps up which is daft as the Fibre routers handle both ADSL/VDSL switching between connection profiles and can be done quickly and effectively and could save money to Isp's having different routers available and just having one type that does both.

Anyways im currently on my second VMG3925-B10C Router as my connection seems very poor when trying to use it for daily use...no matter what device im on i keep seeing "no internet access" or the max WIFI speed under wpa2 security of 12mbs/22mbps to the point my speed tests even keep coming back at 1.7mb and 1kbps upload and im not joking...now while i blame the isp for Packet loss and bad speeds they dont have the answers to solve this so im turning to the community of experts for this router brand.

I have spotted the firmware is slightly out of date on this router compared to whats on the zyxel download homepage (Stock) but what i need to know is do i have generic zyxel firmware or custom ISP firmware that may crash the router if i attempt to update it...the current firmware im running is :- V5.13(AAVF.10)T2 

Now i see the wifi signal from the router reports its outputting 144mbps on 2.4ghz however my devices drop all the time even when sitting right next to the router and cause stutters and glitches & red wifi latency/speed symbols in games pings have been hitting around 800ms - 1200ms and i believe even on wireless N this should be around 300mbps output which the DSL only router used to say so this caught my attention and again the isp has no idea on why this is but got curious on the outdated firmware suggestion and not being up to date but has done nothing about it.

I've walked past the router while going to the bedroom above the routers location and noticed it Flashing Red at times on the 2.4ghz side which got me curious as well but the wifi signal drops badly causing terrible internet to the point i have to keep resetting it to get a new connection.

Is there newer stock software or upcoming beta software i can try to solve these issues or any other ideas that can be suggested as its driving me bonkers now to the point i want to buy my own unlocked hardware.

Kind Regards 

PhantomR1982

Answers

  • HummelHummel Posts: 168  Warrior Member
    edited August 3
    You won't be able to upgrade to the generic firmware (C0) if you are using a customized firmware like V5.13(AAVF.10)T2. The GUI will tell you the generic firmware you are trying to upgrade is not valid.
    To diagnosing your WiFi issue, according to your description, the 2.4G is blinking red but I can't find this behavior in the User Guide. Apparently, there is something wrong with the 2.4G WiFi because normally it should be solid green or blinking green. In your observation, do you still get low speed when the 2.4G LED is green?
  • PhantomR1982PhantomR1982 Posts: 2  Junior Member
    Hiya @Hummel

    Thanks For Replying.

    I Was Afraid of that to be honest with regards to the firmware,that's why i didn't even attempt to download the software or try to update it in case i crashed the router losing all connectivity even though i do have another to plug in via the ISP originally (2 on hand)...but if theres a way to flash/backup there firmware out of the device and install the zyxel stock firmware to test a theory id be willing to try.

    Wifi Issues i dont see the red wifi light flashing all that often and its random when i do see it...if my devices are struggling to play a game on my mobile i look over to it and its either solid green or flashing green or flashing red but its still broadcasting.

    But yes to answer your question we get low speed all the time the xbox reports its wifi speed is connected at 22mbps (wpa2) and this can drop to 12Mbps when issues are going on but my connection speed constantly fluctuates but nowhere near the 30-40mbps guaranteed speed they promised although i see that its 40mbps at the socket with around 6.7mbps upload but we definitely dont feel that when on our devices or watching youtube...local broadband engineers have stated they think its the brand of router and to try another brand but im thinking firmware as its supposed to be outputting 144mbps on 2.4ghz according to the stats page where the previous router reported 300mbps (ZYXEL AMG1302-A11) but i never saw any red wifi issues on that model but it was a connection issue there.
Sign In or Register to comment.