« Back to all recent discussions

install new perl on NAS542

sitrositro Posts: 20  Junior Member
I try to install a new version perl 5.30.2 on the NAS where perl 5.14.2 is already installed with the fun_pkg.
at the step configure I get an error ->

[...]
Where is your C library? [/ffp/lib/libc.so] 
 
Extracting names from the following files for later perusal:
 
/ffp/lib/libc.so
/ffp/lib/libcrypt.so.0
/ffp/lib/libdl.so.0
/ffp/lib/libm.so.0
/ffp/lib/libpthread.so.0
/ffp/lib/libutil.so.0
/usr/lib/libgdbm.so.4.0.0
/usr/lib/libnsl.so.1
 
This may take a while................... 
/ffp/bin/nm didn't seem to work right. Trying /ffp/bin/ar instead...
/ffp/bin/ar: /ffp/lib/libc.so: File format not recognized
/ffp/bin/ar didn't seem to work right.
Maybe this is a Cray...trying bld instead...
Configure: line 6739: bld: command not found
That didn't work either.  Giving up.
[email protected]:/ffp/local/perl-5.30.2# 

have you an idea to solve this error.

Comments

  • MijzelfMijzelf Posts: 1,157  Heroic Warrior Member
    What is your goal? FFP is old, and possibly not capable to support the latest version of perl. Entware will provide you of at least version 5.28.
  • sitrositro Posts: 20  Junior Member
    thanks for your answer,
    My goal is install the last vesrion of logitechmediaserver (v8.0). (see https://forums.slimdevices.com/). The software  provided by zyxel is the SqueezeCenter 7.4 completely obsolete.
    I had already installed the version 7.9.3 a long time ago, when I bought the NAS 542,  with the perl 5.14.2 embeded in the ffp package.
    but it seems from my tests that this version perl 5.14.2  and the version 5.28 from entware package don't run the last version logitechmediaserver 8.0. (Note : the entware package is for kernel linux based on openwrt and not for the kernel from zyxel so the utils like gcc  don't match the kernel version)

    So I tried another way :  install the perl 5.30.2 on the nas with the ffp utilities then the entware utilities. it fails.
    more it seems some kernel library is need to compile perl . the last messages after many attemp are it can't load libnsl.so and libgdm.so libraries which are however in /ffp/lib (but probably don't cover the last nix kernel source, or something like this).
    Say that I am not an expert in perl , but having the latest version of lms would be really cool
  • MijzelfMijzelf Posts: 1,157  Heroic Warrior Member
    Maybe Fonz' original buildscript helps? perl.funpkg

Sign In or Register to comment.