« Back to all recent discussions

NAS540 only connects at 100Mb/s

ombre33ombre33 Posts: 11  Junior Member
Hello,

I have tried different cables, switches, routers. NAS540 will always only connect at 100Mb/s. This is what ethtool has to say:

        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 4
        Transceiver: external
        Auto-negotiation: on
        Current message level: 0x00000036 (54)
                               probe link ifdown ifup
        Link detected: yes



Trying to set the speed manually to 1000Mb/s seems to send the NIC into a state where it keeps toggling on and off every few seconds and only a reboot will make the NAS reachable again.

Not really sure where to go from here and any help would be much appreciated.

Thanks.

Tagged:

Answers

  • TY9527TY9527 Posts: 75  Warrior Member
    It seems the poor cable quality cannot meet 1G speed but you still manually fixed it.
    Have you tried cross-test (cable and port) to rule out the cause?

  • ombre33ombre33 Posts: 11  Junior Member
    Yes I have. But just for good measure, I tried again with a cable and port of a device that I know gets 1000Mb/s. Even there, NAS540 still only gets 100Mb/s.
  • TY9527TY9527 Posts: 75  Warrior Member
    How about another port? are both two ports on your NAS not able to get 1G speed?

    And try fix at 1G speed on both side of link?  NAS540 <---> Switch, Router

    Maybe it's HW issue...
  • ombre33ombre33 Posts: 11  Junior Member
    Trying Port 2 on the NAS was a good idea, and indeed something I hadn't tried yet. But it will still only connect at 100Mb/s.

    Switch won't let me manually choose a speed faster than 100Mb/s.

    HW issue? Kinda doubt that both ports on the NAS are now faulty. And upon start-up of the NAS I can see in the web IF of the switch that the NAS tries to connect to 1000Mb/s, then disconnects, then reconnects at 100Mb/s.
  • TY9527TY9527 Posts: 75  Warrior Member
    edited April 21
    Change another cable for another try? sometimes it just can't fit on specific devices

  • ombre33ombre33 Posts: 11  Junior Member
    Alright, I feel kind of stupid for having to admit this, but I guess it serves me right for not checking the simplest solution first: A good blast of compressed air to Port 1 remedied that problem.

    Thanks so much for your help, still!
  • SwedefSwedef Posts: 3  Junior Member
    Really? compressed air? mine has been like this since i got it (maxing out at about 10-12MB/s) 
  • ariekariek Posts: 11  Junior Member
    edited September 13
    I had a similar issue with a NAS520, suddenly it would only connect with 100 Mbps. I tried different cables but that didn't work. I was able to fix it using the info found in the thread below, read it first. Disable link aggregation if you use that.
    ethtool -s egiga0 speed 1000 duplex full autoneg on
    After this command, reboot the device without any connected network cables. I'm not sure if this is really necessary but in my situatioin is wasn't solved the first time.
    When the device is fully booted up (after 4-5 minutes or so) power it down by pressing the power button. Then connect 1 network cable and reboot the device and check
    Control Panel > TCP/IP > Network Interface
    Status should be: 1000 Mbps, full-duplex

Sign In or Register to comment.