« Back to all recent discussions

HTTPS and Certificate

MarkusMarkus Posts: 2  Junior Member
edited February 10 in Discussions
Hi there,
  I think I need your help:
  I configure a little with the connection "HTTPS only" and the certification and now I do not get access to the web interface.
  Is there a way to disable HTTPS and use normal HTTP using SSH command?

  Nas520

  Thanks for your help!



#NAS_Feb_2020

Comments

  • BatouBatou Posts: 90  Warrior Member
  • MarkusMarkus Posts: 2  Junior Member
    edited February 10
    Thank you! 
    But is there any other way? The reset is my final option. I configured the Nas with many share folders and dns etc. 
    I even create an new certificate with ssh but the browser ignore it. 
  • MijzelfMijzelf Posts: 1,022  Heroic Warrior Member
    Maybe. If you are a bit into Apache. The webinterface runs on Apache, and I *think* HTTPS only is forced by some redirect rule.
    If you remove that redirect rule and restart the webinterface, it might work.

    The config file for the main webinterface is /etc/service_conf/httpd.conf. You can reload the webinterface by

    /etc/init.d/httpd.sh reload

    Don't worry to screw things up. The apache configuration is completely in ram, and is rebuild on boot.
Sign In or Register to comment.