« Back to all recent discussions

FFMPEG not working on NSA325v2. Did I install it wrongly?

AleXSR700AleXSR700 Posts: 34  Junior Member
edited February 7 in Discussions
Hi everyone,
I wanted to install ffmpeg, but it seems I am doing something wrong.

I ran slacker -Ui and then installed ffmpeg.
But I cannot run ffmpeg in shell. It is not being found.
I have ffp and entware-ng installed next to each other, if that matters.

<code>
sudo find . -print | grep -i 'ffmpeg*' ./ram_bin/usr/local/dmsf/binary/cgi-bin/ffmpeg-video-thumb.desc ./usr/local/dmsf/binary/cgi-bin/ffmpeg-video-thumb.desc ./usr/local/zy-pkgs/ffproot/ffp/funpkg/removed/ffmpeg-0.8.7-arm-1,reinstalled,202002 07_034542 ./usr/local/zy-pkgs/ffproot/ffp/funpkg/installed/ffmpeg-0.8.7-arm-1 ./usr/local/zy-pkgs/ffproot/ffp/funpkg/cache/s/ffmpeg-0.8.7-arm-1.txz ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/cfg/org.jdownloader.controlling.ff mpeg.FFmpegSetup.dash2m4acommand.json ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/cfg/org.jdownloader.controlling.ff mpeg.FFmpegSetup.dash2oggaudiocommand.json ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/cfg/org.jdownloader.controlling.ff mpeg.FFmpegSetup.dash2opusaudiocommand.json ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/cfg/org.jdownloader.controlling.ff mpeg.FFmpegSetup.muxtomp4command.json ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/cfg/org.jdownloader.controlling.ff mpeg.FFmpegSetup.demux2m4acommand.json ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/cfg/org.jdownloader.controlling.ff mpeg.FFmpegSetup.demuxgenericcommand.json ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/cfg/org.jdownloader.controlling.ff mpeg.FFmpegSetup.muxtowebmcommand.json ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/cfg/org.jdownloader.controlling.ff mpeg.FFmpegSetup.demux2mp3command.json ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/cfg/org.jdownloader.controlling.ff mpeg.FFmpegSetup.demuxandconvert2ogg.json ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/cfg/org.jdownloader.controlling.ff mpeg.FFmpegSetup.extensiontoformatmap.json ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/cfg/org.jdownloader.controlling.ff mpeg.FFmpegSetup.dash2aaccommand.json ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/cfg/org.jdownloader.controlling.ff mpeg.FFmpegSetup.demux2aaccommand.json ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/cfg/org.jdownloader.controlling.ff mpeg.FFmpegSetup.muxtomkvcommand.json ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/themes/standard/org/jdownloader/im ages/logo/ffmpeg.png.license ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/themes/standard/org/jdownloader/im ages/logo/ffmpeg.png ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/logs/1580741728735_Mon, Feb 3, 202 0 14.55 +0000/org.jdownloader.controlling.ffmpeg.FFmpeg.log.0.lck ./e-data/e9902f35-4024-4b41-9626-08c2131c7087/jd2/logs/1580741728735_Mon, Feb 3, 202 0 14.55 +0000/org.jdownloader.controlling.ffmpeg.FFmpeg.log.0 ./i-data/c7d796b4/.system/zy-pkgs/ffproot/ffp/funpkg/removed/ffmpeg-0.8.7-arm-1,rein stalled,20200207_034542 ./i-data/c7d796b4/.system/zy-pkgs/ffproot/ffp/funpkg/installed/ffmpeg-0.8.7-arm-1 ./i-data/c7d796b4/.system/zy-pkgs/ffproot/ffp/funpkg/cache/s/ffmpeg-0.8.7-arm-1.txz [email protected]:/#
</code>

Any ideas anyone?

Thank you for your help :)


#NAS_Feb_2020

Comments

  • AleXSR700AleXSR700 Posts: 34  Junior Member
    edited February 7
    P.S.: Does anybody know how you can tell slacker to ignore missing checksums.md5? It's preventing me from downloading from e.g. barmelej2.
    It also happens with others and then simply aborts:

    Updating package lists... fetch: rsync -q 'rsync://ffp.inreto.de/ffp/0.7/arm/packages/CHECKSUMS.md5' '/ffp/funpkg/cache/s' fetch: (cd '/ffp/funpkg/cache/mz'; wget -Nnv 'http://downloads.zyxel.nas-central.org/Users/Mijzelf/FFP-Stick/packages/0.7/arm/CHECKSUMS.md5') FATAL: mz: No CHECKSUMS.md5 Thanks for using UW Site Loader! [email protected]:/ffp/bin#
  • MijzelfMijzelf Posts: 1,022  Heroic Warrior Member
    I suppose you installed ffmpeg-0.8.7-arm-1.txz, which contains only libraries, and no executable. You could install ffmpeg-1.1.1-arm-2.txz instead, which also contains a binary.

    About the checksums.md5, you have to edit your /ffp/etc/funpkg/sites, and remove the dead links.


  • AleXSR700AleXSR700 Posts: 34  Junior Member
    So your own link is dead? I get the same error from your server.
    Also, I cannot select to install a different ffmpeg because there is none on any of the working servers :(
  • MijzelfMijzelf Posts: 1,022  Heroic Warrior Member
  • AleXSR700AleXSR700 Posts: 34  Junior Member
    Okay, got it running now, thank you :)

    However, the ffmpeg in your own repository does not include the libshine.so and therefor does not work. I had to install the br2 version.
    For some reason jDownloader still claims that FFMPEG is missing :(


    ffmpeg version 0.10.2 Copyright (c) 2000-2012 the FFmpeg developers  built on Apr  2 2012 13:27:15 with gcc 4.5.4 20111110 (prerelease)  configuration: --prefix=/ffp --disable-static --enable-shared --enable-gpl --enable-nonfree --enable-small --disable-encoder=aac --disable-decoder=aac --disable-armv6 --disable-armv6t2 --disable-armvfp  libavutil      51. 35.100 / 51. 35.100  libavcodec     53. 61.100 / 53. 61.100  libavformat    53. 32.100 / 53. 32.100  libavdevice    53.  4.100 / 53.  4.100  libavfilter     2. 61.100 /  2. 61.100  libswscale      2.  1.100 /  2.  1.100  libswresample   0.  6.100 /  0.  6.100  libpostproc    52.  0.100 / 52.  0.100Hyper fast Audio and Video encoderusage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

  • AleXSR700AleXSR700 Posts: 34  Junior Member
    Okay, got ffmpeg up and running with your version. Had to install a few more things


    ffmpeg-1.1.1-arm-2, x264-20130313-arm-1, twolame-0.3.13-arm-1, shine-20130313-arm-1, rtmpdump-2.3-arm-1, opus-1.0.2-arm-1, fdk_aac-20130313-arm-1, 
    libass-0.10.1-arm-1, freetype-2.4.11-arm-1, fribidi-0.19.5-arm-1, fontconfig-2.10.91-arm-1
    But jDownloader still won't work. Tried setting the path to '/ffp/bin/' but jDownloader just tells me that the new value could not be set.
  • MijzelfMijzelf Posts: 1,022  Heroic Warrior Member
    Don't know if my version is better than br2's. It's long ago that I created the package on request.

    And sorry, I have no idea how jDownloader expects to find ffmpeg.
Sign In or Register to comment.