« Back to all recent discussions

NAS540 "volume is down" after firmware upgrade

elbosotielbosoti Posts: 1
edited January 28 in Questions
I recently decided to upgrade my firmware for the nas540, it was on version 5.04 AATB0, which didn't work at first. I managed to manually update it to 504AATB0_20150813.bin and then I was able to update it to the latest version (v5.21). but after updating it I couldn't log into it anymore so reset the password and ip. But now it's showing up as "volume is down" on the web interface and on the nas seeker it says it needs to be initialized.
I managed to get into the telnet connection and get this from the cat command:

~ # cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md2 : active raid5 sdb3[0] sde3[3] sdd3[2] sdc3[1]
      17569172928 blocks super 1.2 level 5, 64k chunk, algorithm 2 [4/4] [UUUU]

md1 : active raid1 sdb2[0] sde2[3] sdd2[2] sdc2[1]
      1998784 blocks super 1.2 [4/4] [UUUU]

md0 : active raid1 sdb1[0] sde1[3] sdd1[2] sdc1[1]
      1997760 blocks super 1.2 [4/4] [UUUU]

unused devices: <none>
I am not at all familiar with RAID5 and would like to get it back up and running



#NAS_Jan_2020

Best Answer

  • MijzelfMijzelf Posts: 1,073  Heroic Warrior Member
    Accepted Answer
    Here is your problem: 17569172928 blocks

    On firmware 5.0x volumes up to 256TiB were supported, on 5.10 and up only 16TiB.  I wrote about the technical background here.

    So you'll have to downgrade to get your volume back.

    When 5.10 was launched, ZyXEL had some tool/workaround to shrink the volume first to <16TiB before upgrading. But I don't know how they managed to change the block size of the ext4 filesystem.



Sign In or Register to comment.