« Back to all recent discussions

NAS540 Web Interface

VictorVictor Posts: 5  Junior Member
edited January 28 in Questions
I had problems with my previous NAS540 getting the web interface to open. I contacted tech support and we troubleshoot for over an hour until they decided it was a hardware issue and sent me another NAS540. I got it today and installed it as per the instructions, however I am still not able to open the web interface to change security, backups, etc.

I have tried both, through http://nas540 and the ip address, both with same results. I have manually opened port 80 in router for NAS. I have turned off windows security firewall, I tried opening from an InPrivate window. I have also removed all security for the addresses, accepting popups, cookies, etc. 

The NAS540 is connected behind an unmanaged switch and has a static IP address assigned by my Google router. 

Also, I am able to access the 4 HDD through my network and I am able to use the Cloud through network and my phone remotely.  In short, everything works as expected except the web interface...and this is what was happening with the old NAS540 as well!!

I am at a loss. Any help would be greatly appreciated!

NOTE: Forgot to mention the NAS Utility tool can also see the NAS and the firmware version is V5.21(AAATB.3)


#NAS_Jan_2020

Answers

  • MijzelfMijzelf Posts: 1,073  Heroic Warrior Member
    I cannot imagine any hardware error which can kill the webinterface and leave the samba server.

    What exactly happens when you go to http://nas540? What is the error message of the browser? 
  • skoobskoob Posts: 26  Junior Member
    Hello @Victor,

    yes, please provide more info what the exact error message is.
    In addition you can use a port scanner like NMAP to check if and which ports are open.

    Of course try http and https.
    Make sure that no antivirus software is blocking anything (Bitdefender is known for that). So check the logs of your antivirus.

    Make sure to use private / incognito mode in web browser and to disable all plugins.

    Greetings.
  • VictorVictor Posts: 5  Junior Member
    Thanks for the responses! 

    When I go to:

    HTTP://NAS540   Nothing seem to happen. At first the address in the address bar changes to http://nas540/r51166,/desktop,/login.html but it keeps trying to load but it never resolves. Sometimes it will go as far as to show me a gray screen. Some other times will go as far as to try and load t he page elements but usually shows the color squares and outline but nothing else (no user ID or password fields or anything else).  I don't have screenshots of the latter two because 99% of the time what I get is just first scenario



    HTTPS://NAS540  I get a "This Site can't be reached" message with the following error:  ERR_CONNECTION_REFUSED. Screenshot attached.



    I get the same responses whether or not I try through regular Chrome window or in-private.I tried both with add-ons enabled and all add-ons disabled with the same outcome.

    I get the same results when trying on Microsoft Edge.

    My external IP address sees ports 8080 80 5000 8081 open

    I have a Security Suite provided by my cable company but it doesn't add a firewall and I have the Browsing Protection turned off.
  • skoobskoob Posts: 26  Junior Member
    Hello @Victor,

    are you trying to access the NAS from the internal network or external network?

    As a last resort you can perform a full reset of the NAS, the data on the drives remains untouched, but you might have to confgure users and shares again.

    Greetings
  • MijzelfMijzelf Posts: 1,073  Heroic Warrior Member
    The webserver is running. That change from http://nsa540 to http://nas540/r51166,/desktop,/login.html is caused by a redirect send by the server.
    The login page (as well as all other pages) are generated by a python script, which seems to be stalling.

    Does this problem also show up when you remove the disks? There might be some misconfigured package.

  • VictorVictor Posts: 5  Junior Member
    I went ahead and did a factory reset and tried again to connect with the same results. I then took off all 4 HDs and had no change in results either. When I went to my NAS Starter Utility, however, the "Desktop" button was grayed out.


    Regardless I power down the NAS and powered it back on just to make sure the reset took place and when I tried to go to http://NAS540 and after letting the browser "think" for about 25 minutes I got slightly further (see below) but still not the whole interfacE.

    I am thinking that there is probably some issue with my RAID or one of the HDD even though when all 4 are in it shows as ready. Is there a way to wipe the HDD clean so I can try and initialize them?
  • MijzelfMijzelf Posts: 1,073  Heroic Warrior Member
    When you don't get a web desktop when the disks are out, I don't think the disks can be the problem. But if you simply remove the partitions the disks will be seen as new. That can be done in the NAS itself, but then you need ssh access, which has to be switched on in the webinterface...

    It's baffling that you have the same problem with 2 different samples of the NAS. The only conditions that didn't change is the disks and your own network, right? AFAICS you excluded the disks, and so the network remains. The NAS is connected to a switch. How is your client connected? Is it possible to connect it to the same switch? Can you exchange cables and switch? If you don't have a spare switch, maybe connect them to the router. Or use a direct cable between client and NAS.
  • skoobskoob Posts: 26  Junior Member
    Hi @Mijzelf and @Victor,

    I guess at this point it is very likely that the network or the client computer could be the cause.
    Please also try to access the NAS from a different device, a different computer or a smartphone.

    Maybe this is working and you can rule out the network, but maybe it is rather related to your computer.

    greetings.
  • VictorVictor Posts: 5  Junior Member
    Yeah I am at a loss too. And as far as changes, the disks did not change but the network did as I went to a Google wi-fi mesh system with a different SSID.  I have the client connected to the switch as well though and everything else in my network is operating just fine.

    I tried using a different port in the switch as well as a different cable with same results. I didn't think that would work since I can see the Cloud just fine


  • VictorVictor Posts: 5  Junior Member
    Welp...so I went to change the cable for the third time and this time I decided to connect it to the second port in the NAS (LAN2) and interestingly enough...it started working!!  the issue now is that the router assigned it a completely different IP address than the static one I assigned.  

    Bottom line, it is working so I will just delete the IP reservation and move on with life. 

    Thank you all for your help!!!

     
Sign In or Register to comment.