« Back to all recent discussions

WebDAV works only on local network, mycloud setting keeps turning WebDAV off

TomasMalinaTomasMalina Posts: 16  Junior Member
edited January 17 in Questions
Hi,
I'm trying to mount my drives in NAS542 as network drives, I've used RaiDrive for that and followed the instructions in the Youtube tutorials and in this thread https://homeforum.zyxel.com/discussion/comment/6528
However, even after setting the port forwarding on my router (port 5003), I can't seem to be able to access the drive from an outside network. I can connect just fine over WebDAV when I'm on the same local network as the NAS.

Moreover, when I was making sure that this feature is allowed in the mycloud.zyxel.com settings, whenever I trigger some settings and revisit it, it appears as if to be turned off. If I toggle it, is says that the changes were successfull on the next page, but if I come back to the UPnP settings, all the toggles (except for http) are shown as off.

I tried reinstalling the app (my zyxel cloud agent), even reinstalling the firmware (v5.21 abag3), but the only change was that initially all the toggles reverted to off, and after the reinstall, all but http revert to the off position. Also, sometimes the port numbers change automatically and even if I confirm the change with a different port number, I can still access the NAS on LAN over WebDAV through the original port 5003. 
I wanted to set the port forwarding on the NAS itself (Control Panel, Network, UPnP Port Mapping) to be sure the router isn't the culprit, but I cannot see the option to do so (I can't even see the http/https protocols).

Moreover, the mapping conditions change without my intevention, on their own. At first, there was a WEBDAV condition set for ports 5003, later a STREAM condition appeared, and now WEBDAV disappeared and was substituted by HTTP (however, I can still access the drives mounted with RaiDrive via the port 5003). I have no idea what's happening here, if I toggle the mapping off or change the WAN port (eg. of the STREAM), it doesn't stick - I just confirm a dialog, it's loading for a while and then it displays the same things as there were before.

To be precise, I cannot access the nas through the DDNS setup in mycloud from anywhere (outside or inside LAN), if I type in https://[nas_name].zyxel.me:8001, I get an ERR_CONNECTION_REFUSED, if I use the port 443 instead (that's the https port shown in the NAS TCP/IP settings), it hangs for a bit and then gives a timeout error. I'm confused what ports are actually used - the Web Configurator in webinterface shows some port numbers, the mycloud settings show different numbers. So far I'm logging into the webinterface via local IP address.

EDIT: So I toggled the HTTP setting in mycloud agent and now it reverts back to off again, like all the other toggles, upon saving as on.
Also, the UPnP settings really got copied to the router settings, even though the webinterface doesn't show it:



#NAS_Jan_2020
Tagged:

Best Answer

  • DashDash Posts: 52  Warrior Member
    edited January 17 Accepted Answer
    What is your network topology?
    Can you share the port forward rules of your router?
    And what it the configuration on RaiDrive?

    Below is my screenshots:
    Accessing web interface (HTTPS) of my NAS from outside via Chrome.

    Accessing WebDAV (HTTPS) of my NAS from outside via RaiDrive.


    I don't configure UPnP, only set port forward rules on my router.
    - Paired my NAS on myZyxelCloud and set DDNS.
    - Port forward [external port <-> internal port] as 8483 <-> 443 and 5883 <-> 5003.

Answers

  • TomasMalinaTomasMalina Posts: 16  Junior Member
    edited January 17
    I have a router connected to PC and NAS via ethernet cable, other devices connected by wifi. Once in a while I connect my PC to NAS ad hoc, to the second NIC card. 
    Port forwarding rules are screenshot above - 5003 <-> 5003, 443 <-> 443 etc. 
    My RaiDrive is configured ike this:

    I have re-paired the NAS to my mail account and now I'm able to access it over https://[my nas].zyxel.me:port from the local network, but still no luck trying from the outside.
    I'll try forwarding different port numbers.
    EDIT: Ok, so I tried forwarding the same ports as you have to the ports that work from local network, but still no luck connecting to my NAS. RaiDrive says "connected host has failed to respond"
  • DashDash Posts: 52  Warrior Member
    Do you able to access web interface of your NAS542 from outside through DDNS?
    Does your network environment exist double NAT?
  • TomasMalinaTomasMalina Posts: 16  Junior Member
    edited January 20
    No, I cannot, not from the outside. All this works fine from the local network, however, not from the internet. (That is, I can load the webpage https://host_name.zyxel.me:port_number when I'm on the same network as my NAS, but not when I'm some place else. The same goes for webdav).
    No, I have a router that's configured as my access point and that's it, NAS and all other devices connected directly to the router.
    I'll try a different router sometime this week to determine whether that is not the cause of problems, I'll post the result.
  • DashDash Posts: 52  Warrior Member
    What is WAN type of your router? DHCP or PPPoE or ...
    Does WAN IP of your router as Public IP or Private IP?
  • TomasMalinaTomasMalina Posts: 16  Junior Member
    PPPoE.
    I'm not sure, but I'd say it's the public IP? How do I find out for sure?
  • DashDash Posts: 52  Warrior Member
    You can check the status page of your router, it should has WAN IP information.

    And you can try to ping the domain name (host_name.zyxel.me), the result of IP should be the same with your router's WAN IP.

    Or checked it on myZyxelCloud (https://mycloud.zyxel.com/).

  • TomasMalinaTomasMalina Posts: 16  Junior Member
    edited January 21
    OK, so I have reconfigured the NAS on a different network (with a different router) and the WebDAV works fine from the internet. It seems then that my router didn't work as expected, that it didn't forward the ports even though the rule was set there. I'll have to have it exchanged. 
    Thank you very much for your assistance! :smile:
  • TomasMalinaTomasMalina Posts: 16  Junior Member
    edited January 24
    Well, now, I had it exchanged, but the connection still doesn't work from the outer network at my home. 
    I was able to configure the NAS without any problems at my parents' house where they have a modem and an ASUS router plugged in (RT55U), everything worked fine by just allowing the port forwarding rule in the router.
    At my home, however, I have a TP link router (provided by my ISP), and when I take the exact same steps to configure the WebDAV, it doesn't work. Port forwarding rules set, NAS DDNS set, UPnP allowed... I have tried to check my ports at canyouseeme.org, but I get a timeout error at the ports I've set for WebDAV and http(s), indicating that the NAS is not responding.
    Any ideas what else could be wrong with my setup?
  • TomasMalinaTomasMalina Posts: 16  Junior Member
    Ok, final update! The problem I had was that port forwarding was disabled by my ISP. Once I called them and they disabled this security feature (they said it's the default for customers with dynamic IP), everything works fine now. Again, thanks for help!
Sign In or Register to comment.