« Back to all recent discussions

[VMG8924-B10A] Factory Reset as a result of Power Outage?

HyFyHyFy Posts: 8  Junior Member
edited October 16 in Discussions
Hello, 
I have a VMG8924-B10A supplied FOC during a recent supplier change.  The firmware is: 1.00(AAKL.24)C0.
I have a number of bits and pieces connected to the WLAN and I won't say that the transfer was seamless. BUT after a while things have been running okay. There are a few raspberry Pis on static IPs including one which chats with  an IOT site and another which is a server in it's own right. They all inter-communicate via MQTT/paho.
SO when we had a 15 minute local power outage this afternoon, I was surprised when nothing re-started as it should have done on re-supply.  When I tried to connect to the router, it was apparent that the previously installed password had been re-set and we were back to "admin" and "1234".  Then I found that the Port Forwarding rules and the Dynamic DNS were no longer operational. They had been deleted.
i.e. The router seems to have carried out a Factory Reset.
Is this normal with this router? If not why may this have happened on this occasion?
I am away from home for long periods and the Raspberry Pis tell me what is happening security and weather-wise at my home.  I doubt I can correct a factory reset from a distance so I could do with knowing if this is an issue which I have not faced with other routers.

Thank you for any suggestions or information.

HyFy


#SP_Oct_2019

Comments

  • HummelHummel Posts: 50  Warrior Member
    edited October 16
    @HyFy
    Is this the first time you meet the problem?
    Can you always see the problem when there is a power outage?
    As I know, when the CPE meets power outage, it still keeps the current running settings and won't perform a factory reset after power on.
    There is a possibility that your CPE is reset by ISP.
    If this problem only happen once, maybe you could contact your ISP to check if your device is reset by the ISP.
  • HyFyHyFy Posts: 8  Junior Member
    Thanks for that.
    This is the first time there has been a power outage since I have been using this router and the first time it has reset.  I will contact the ISP but I don't hold out much hope for a sensible response.  The last time I queried something about the router, I was asked if I had working Broadband. I replied, "Yes-but..." at which point the call was disconnected!!
    I will let you know what they say.

    HyFy.

  • HyFyHyFy Posts: 8  Junior Member
    Hi,
    I spoke to the ISP and apart from the "do you have working Broadband at the moment?" I tried to persist and ask if they had reset my router in the event of a power outage. They asked two questions, "How would we know you had a power outage?" and "Why would we reset your router from this end?"  I asked if it could be done locally, i.e. by BT staff at the local exchange. "Ask BT." was their response.
    I think that I will be changing my ISP at the earliest...
    Can you help with their questions?
    I won't be bothering with BT.  They left me unplugged for two days blaming something here, inside my place. 10 minutes before the engineer was to arrive it magically started working after he had found it unplugged at the exchange!! But they had nothing to do with the power outage so...

    I guess I could experiment with switching it off at the outlet and seeing what the results are!!!

    HyFy
  • HummelHummel Posts: 50  Warrior Member
    @HyFy
    Please test it just like you said to switch it off at the outlet and see if the device is reset after you power it on again to simulate the power outage situation. It will be helpful to clarify the problem. Remember to modify the configurations so that you could know if it is reset or not.
  • HyFyHyFy Posts: 8  Junior Member
    As it takes a time to reset everything it will have to wait until after the "working day"!
    I'll let you know.

    HyFy
  • HummelHummel Posts: 50  Warrior Member
    @HyFy
    You might need to backup your current running configuration before testing so that you can restore all your settings after your test.
  • HyFyHyFy Posts: 8  Junior Member
    ...and that is done how?...

    Sorry to be a pain but...

    We have to learn somehow!

    HyFy
  • HummelHummel Posts: 50  Warrior Member
    @HyFy
    My suggestion is that after you configure your device, you can backup your current configuration by exporting it via WebGUI. You can go to the page from Menu -> Maintenance -> Backup/Restore. Then you can press the backup button to export the current configuration and save it in your PC/Laptop. Then when you meet any configuration problem, you can restore your configuration easily without configuring it manually again.
  • HyFyHyFy Posts: 8  Junior Member
    Thanks.  I will now try to power it down and see what happens!
    HyFy
  • HyFyHyFy Posts: 8  Junior Member
    Hello again Hummel

    I have powered the router down for a series of times between 1 and 10 minutes.  On each occasion everything was re-set.  Not only that, when I restored the configuration file, the router wanted to re-start automatically which re-set all of the rules etc. I was forced manually to re-input the rules and changes.

    The english saying: " about as good as a chocolate teapot " springs to mind!!

    This router, if this is as good as it gets, is not good enough for my purposes as I cannot re-input the setting remotely, I will have to seek re-dress and look elsewhwere

    But in the meantime if you have any other thoughts please let me know...

    HyFy
  • HummelHummel Posts: 50  Warrior Member
    edited October 25
    @HyFy,
    What kind of settings did you change in your test?
    I notice that 1.00(AAKL.24)C0 is not the latest firmware of VMG8924-B10A.
    Maybe you could give it a try with the latest firmware to see if the problem still happens or not.
    I also ran a test with the same 1.00(AAKL.24)C0 firmware.
    I changed the password of admin account and WiFi SSID and then powered it off for several times. I can still use the new password to log in the WebGUI and the SSID is not reset to default value.
    If your problem still can't be resolved after trying the latest firmware, my suggestion is to contact Zyxel local support because it seems like a single case problem.
  • HyFyHyFy Posts: 8  Junior Member
    Thanks for that Hummel.

    I will update the firmware and try again.
    Thanks for your attention.

    HyFy
Sign In or Register to comment.