« Back to all recent discussions

Router LTE3301 bridged mode with server

juhazjuhaz Posts: 4  Junior Member
edited June 10 in Questions

Hi. How does that bridged mode supposed to work? Does it work with server?

I have had hard times to configure my LTE3301 to deliver my public IP to the server.

Have tried: Routed on, Firewall off, NAT off and DHCP Off. No luck.

At the times of ADSL modems, the bridged mode completely disables the modems own services except connection and made it inaccessible from inner network and server got the IP straight from the ISP.

Any ideas?

/juhaz



#SP_Jun_2019
Tagged:

Best Answer

  • bbbbbb Posts: 12  Junior Member
    Accepted Answer
    Hi Juhaz, 

    Regarding Elisa's LTE public IP address services, I think I know what happens to the service. Could you please go to the LTE3301's web GUI. On the Management WAN settings page (Configuration > Network > WAN > Management WAN > Modify), what are the settings? Do you switch to manual dial-up profile and manually fill in the APN, account (username) and password here?

    If you do not manually configure this page, the router would automatically use the APN it already knows trying to connect to the Internet. In general, most of the telecom service providers accept "internet" as the APN, but with this APN you would only have basic services. For example, public IP address is not leased to you. If you want to have a public IP address, Elisa should provide the APN, its corresponding APN username and APN password to you, which should be manually filled in to the LTE3301. 
    In short, if you are not sure what APN you should use in order to acquire a public IP address, please contact Elisa's support team. 


    Regarding how bridge mode works on the LTE3301, to be more specifically, the LTE3301 would forward its WAN IP address to the "LAN client" which connected to the LTE3301 "first". With the forwarded IP address the first-connected LAN client can connect to the Internet. The other clients, including wireless client, cannot connect to the Internet.

    Regarding the behavior comparison between OpenSuse and Ubuntu, I'd say that OpenSuse's behavior is consistent to what I think the LTE3301 should be - only bridge mode should be configured, the other settings should be kept the same; the LAN client should connect to the Internet after enabling bridge mode.

    Regards, 

    Bob

Answers

  • bbbbbb Posts: 12  Junior Member
    Hi, 

    If the network topology looks like the following diagram and you would like the LTE3301 to forward its public IP address at WAN side to the server, you can simply enable bridge mode, you don't have to disable DHCP server or NAT at the same time. In short, the only configuration you have to do on the web GUI is to enable bridge mode (Configuration > Network > WAN > Management WAN). 

    Internet/LTE core network  ))))))(((((( LTE3301 ------ server
  • juhazjuhaz Posts: 4  Junior Member

    Hi bbb, and thanks for your kind answer!

    Yes the topology is correct like you mentioned. I got at console 100.98.22x.xxx -type IP at the server (same in Zyxel status page). When I try via browser like “whatismyip.com” I got 85.76.13x.xx -type IP.

    Both IPs are not reachable and can’t ping from outside (other network). Strange thing is that whatismyip.com sees those both addresses.

    Browser/whatismyip.com gives also: “Your hostname: 85-76-13x-xx-nat.elisa-mobile.fi”

    With only bridge enabled at the router my server sees only 192.168.xx.xx -type inner network address. And no internet connection. So need to disconnect NAT, DHCP and Firewall too.
    Could my ISP have another NAT between…?

    Looks like bad news to host service:

    https://en.wikipedia.org/wiki/IPv4_shared_address_space

    and

    https://en.wikipedia.org/wiki/Carrier-grade_NAT

    /juhaz
  • bbbbbb Posts: 12  Junior Member
    Hello Juhaz, 

    Yes, when I see the IP address "100.98.22x.xxx" you wrote, I immediately think of the Wikipedia page about Carrier-grade NAT. I know that the IP range "100.64.0.0/10" is frequently used by many LTE service providers, and it may confuse end users. In short, this is a private IP range. That's why you saw another IP address "85.76.13x.xx" from the website "whatismyip.com", and I suppose that the server which used "85.76.13x.xx" would not reply ping. 

    In order to use the LTE service with a public IP address, I suppose that Elisa Finland also allows users to apply the LTE rate plan with premium monthly fee. I know that DNA had this kind of service back in 2015, 2016 but am not sure about Elisa right now. 

    Coming back to the LTE3301's bridge mode, I'd like to focus on specifically the following sentences - "With only bridge enabled at the router my server sees only 192.168.xx.xx -type inner network address. And no internet connection." 
    My question: do you mean that the other devices(not the server) connected to the LTE3301 do not have Internet connection when the LTE3301 is running bridge mode? 

    Regards,

    Bob
  • juhazjuhaz Posts: 4  Junior Member

    Hello bbb,

    and thanks for your detailed comment!

    I do have purchased the ”Public IP” at Elisa ISP and have used it in hopes to get the real public IP to the server, but not such luck yet. Not sure yet do they have still another premium service for LTE users but I am working on it.

    Answering your question: other devices like laptop with wireless connection will lost its connection. WLAN is up but internet connection is down. I Use cable connection only for main host. Thought that all routers give only one connection when bridged.

    Looks like my OpenSuse 15 Leap works little different than my Ubuntu server. OpenSuse keeps connection when switching from factory settings to bridge mode. This time I changed only bridge mode NOT firewall, NAT or DHCP.

    So my Ubuntu server lost its connection if I wont disable firewall, NAT or DHCP also. Server have quite tight settings and have firewall, DHCP, DNS etc services configured so that may make the difference. Hope that was what you answered.

    That "85.76.13x.xx" -type address is supposedly my “real public IP” and wont reply ping neither form inner network or from internet side.

    Best,

    /j

  • juhazjuhaz Posts: 4  Junior Member

    Hello Bob,

    and thanks for your relevant comment!

    I think you are right on the point. Talked today with my ISP (Elisa) and got the configuration for APN just like you mentioned.

    Now I got real Public IP at my Zyxel 3301 status screen and also my OpenSuse client gets that wright.

    Here are the settings:

    At: Network > Internet Connection > Management WAN > Modify

    At manual mode should be set like this:

    Country: Finland

    Service provider: Saunalahti

    APN: internet4

    Bridge: Enabled

    No Account or Password.

    Sooo, nice progress today. My Zyxel 3301 works nice now with my setup. My Suse is a basic client and works great too. My Ubuntu server needs though some more love. Needs to go thru the settings and test them.

    Anyways looks great and Big Thanks to Zyxel Forum and Bob for kind and professional help!

    /j


Sign In or Register to comment.