« Back to all recent discussions

NAS326 - Where is the 1,2tb gone?

määckmääck Posts: 4  Junior Member
edited March 18 in Questions
I recently tried to extend one of my volumes, and the usage of disk group 1 was correctly put to 100%, but the 1,2tb never showed up in the volume. It's now just gone!
I attached a screenshot of said disk group. You can see that the volume is only 2,4tb while the disk group has a usage of 3,6tb. This is the only volume in this disk group.
Has someone a clue what is going on and how I can get my disk space back without deleting the whole volume?



#NAS_Mar_2019
Tagged:

Best Answer

  • MijzelfMijzelf Posts: 572  Heroic Warrior Member
    Accepted Answer
    It seems that the volume is bigger than the embedded filesystem. Did you interrupt the resizing procedure?
    Anyway, resizing the filesystem should be a breeze. Simply execute
    su
    resize2fs /dev/vg_5809fa3c/lv_94593aed



Answers

  • MijzelfMijzelf Posts: 572  Heroic Warrior Member
    Can you login over ssh, and post the result of
    cat /proc/partitions
    cat /proc/mdstat
    su
    vgscan
    lvscan -a
    The first command will show all blockdevices (disks. partitions, raid arrays, ...) known to the kernel. The second will show all raid arrays, their status and members. The 3rd command will elevate you to root. (SuperUser), and the 4th will show all  volume groups, and the 5th all logical volumes.
  • määckmääck Posts: 4  Junior Member
    Hey, 
    I put the commands into the ssh, here is the result:

    Thanks for the help!
  • MijzelfMijzelf Posts: 572  Heroic Warrior Member
    Hm. That doesn't tell where your space is gone. You have 3 volumes, 3.63TiB, 1000GiB and 859GiB. These are located in different disks, and can't interfere.
    That 3.63TiB volume doesn't seem to be divided in 'sub-volumes'. So either the filesystem is smaller than the volume, or it's a (cosmetical) bug in the webinterface.
    The command
    df /dev/vg_5809fa3c/lv_94593aed
    can tell you about the [email protected] space of the filesystem on the 3.63TiB volume.
  • määckmääck Posts: 4  Junior Member
    Hey, I ran the new command, here is what it says:



    I don't think it's just a bug in the interface, since Filezilla and the Finder also tell me the size of the volume in question is 2,4tb rather then 3,6tb
  • määckmääck Posts: 4  Junior Member
    Awesome, that worked! Thanks a lot for your help Mijzelf!
Sign In or Register to comment.