« Back to all recent discussions

Multy X not turning on

EepermanEeperman Posts: 4  Junior Member
edited March 17 in Discussions
Hi all

i bought a pair of Multy Xs on eBay and on arrival neither one will power on. I have checked the AC adaptors on my existing Multy X and also tried plugging the new Multys in using my existing AC adaptors. I have also tried factory resets on both. 
The seller seems legit, he has offered to refund me and says they were both working fine. It does seem odd that both of them are defective in the same way. Is there anything obvious I may have missed before I send them back?

Many thanks

#MultyX_Mar_2019

Answers

  • HanamichiHanamichi Posts: 83  Warrior Member
    Do you mean when you plug in its power adapter, both Multy X cannot power on?
    If you used Multy App, can you install them?
  • EepermanEeperman Posts: 4  Junior Member
    Neither one powers on and I can’t install them. No lights appear on the top and when I do the factory reset there is no flashing red light. 

    It seems like they are totally bricked, but it seems odd that both should be the same. 
  • HanamichiHanamichi Posts: 83  Warrior Member
    It seems hardware damage that LED no light and you cannot install them via Multy App.
Sign In or Register to comment.