« Back to all recent discussions

[VMG8825-B50B] USB port runs slow on file transfer

HaikoanHaikoan Posts: 6  Junior Member
edited February 2019 in Discussions
Hi all,
I have just installed the VMG8825-B50B and works well except for the Hard disk connected to the USB 3.0.

when i transfer every type of file it reaches peaks of 3MBps and then slow down to an average of 300kBps. tried to trasfer from different laptops and tried to connect different hard disks, same story.

#CPE_Feb_2019
«1

Comments

  • AAAALAAAAL Posts: 125  Warrior Member

    Hi Haikoan,

    What’s your firmware version?
    What’s your connection between the Hard disk and computer? Use wireless or Ethernet cable?
    And what’s your internet connection average of throughput?
  • HaikoanHaikoan Posts: 6  Junior Member
    Fw version is V5.13(ABLZ.0)b10_20180319

    Hard disk is connected to the USB of the zyxel and connected to the computer through wireless (tried both 5ghz and 2.4ghz no difference in terms of speed, both are slow)

    Internet connection on wireless is 300mbps in download on 5ghz and approx 40mbps in 2.4ghz
  • AAAALAAAAL Posts: 125  Warrior Member

    Hi Haikoan,

    May I know what’s the client you used for the 2.4g and 5g download? The smart phone or laptop?
    Is it a single case on your hard disk devices? Have you took the other USB and have the same issue (300Kbps)?
  • TremorsTremors Posts: 7  Junior Member
    Hello.
    I've got the same issue here. The file transfer to the HDD connected to the USB port of the Zyxel is very slow. My PC is connected through Ethernet cable to the router, but copying files to the HDD with Windows Explorer takes ages. So I tried with an FTP Client (Filezilla), but this way the files are not copied because of a TLS security error.
  • HaikoanHaikoan Posts: 6  Junior Member
    edited February 2019
    Hi AAAAL,
    Thanks for the feedback. 

    I tried with explorer and torrent. With torrent the local download runs as fast as expected,  but with remote HDD on the zyxel USB starts the peak of 2/3 seconds to normal speed then slow down on 300kbps or slower. Tried both on smartphone and one laptop with 2.4ghz wifi and another laptop with 5ghz wifi. No differences.

    Tested the file transfer on the HDD USB directly connected to the laptop, speed runs as expected. 
  • HaikoanHaikoan Posts: 6  Junior Member
    To bypass the problem I connected my netgear router via ethernet, which USB ports are working fine. 

    Very disappointed about zyxel quality
  • AAAALAAAAL Posts: 125  Warrior Member

    Hi Haikoan

    May I know what’s your HDD USB devices? Is it possible to provide the devices model name?
    Is it use the USB3.0 interface or 2.0?
  • HaikoanHaikoan Posts: 6  Junior Member
    Maxtor D3 4TB and 2TB with USB 3.0

    Now connected to the netgear (connected via ethernet to the zyxel) both are working at the expected speed. 
  • AAAALAAAAL Posts: 125  Warrior Member

    Hi Haikoan,

    I take my VMG8825-B50B and test USB throughput, the result is as expected.
    So it may need to be a compatibility problem between Maxtor D3 and VMG8825-B50B.
    Will try to find one and test it.
  • HaikoanHaikoan Posts: 6  Junior Member
    Thanks AAAAL, is there any compatibility list for USB devices? Which HDD model did you connected to the VMG8825-B50B? 
  • TremorsTremors Posts: 7  Junior Member
    edited March 2019
    Hi AAAAL.
    Just for information, my external HDD is a 1 TB USB 3.0 Toshiba DTB310. My PC is connected through Ethernet cable to the router, but the transfer rate copying files to the hdd is as low as 500/600 Kbps. Is it a compatibility problem? I might try with a different hdd.
    Now that I've got the last firmware b7_20180810, I hoped it was solved but it's not the case actually.
  • AAAALAAAAL Posts: 125  Warrior Member

    Hi Haikoan,

    We do not have a compatibility list for USB connection, it has too many various kinds.
    I use my Transcend series and WD HDD with USB3.0 for connecting.
  • stefano_sbstefano_sb Posts: 14  Junior Member
    Hi, what filesystems do you use? NTFS? exFAT?
  • txmxertxmxer Posts: 4  Junior Member
    Hi, new here.  Sorry to dredge up an old thread, but it's related to my issue and I have a work around that's great.  Connecting my USB 3.0 MyBook to the NAS USB ports resulted in slow transfers of 10-20 MB/s as well as errors on some files that I couldn't transfer.  I tried to use the copy/sync function and using a Web interface and the transfer speeds were still painful trying to backup TB's of data. 

    I moved the USB drive to my computer's USB 3.0 port and now I'm seeing 100 MB/s transfers over LAN using Windows Explorer copy function.

    Yes, I'm thrilled with that.  But not satisfied that I can't do the same with the local USB ports on the NAS. 

    The USB drive is EX-FAT, but from all I've read the format has only marginal performance differences.  The ports on the NAS are working like USB 2.0 IMO. 

    Hope this helps if someone else is running in to this issue.
  • HummelHummel Posts: 155  Warrior Member
    edited February 24
    @txmxer,
    Suggest you to create a new post to ask your question because VMG8825-B50B is not a NAS but a CPE (router). Since your question is about NAS not CPE, I think this is not a correct post for your problem.
Sign In or Register to comment.