« Back to all recent discussions

Entware-ng on NAS326 (3rd party zypkgs)

alfaalfaalfaalfa Posts: 6  Junior Member
edited February 11 in Questions
I'm newbie here. I wanted to install Entware-ng using Meta Repository. Unfortunately after installation I was not able to use it normally. I have to do manually after each reboot:
PATH=$PATH:/opt/bin:/opt/sbin
export PATH
Then it seems to work. My question to you guys is: where/how to place a script in order to run these commands on boot. I have tried to put a shell script in /i-data/.system/zy-pkgs, but it seems not to be executed there. In system (e.g /etc/profile) folders its impossible to edit/save files. Probably a script to modify /etc/profile on boot is a better choice, but again, where/how to place it? Thank you in advance for help!

#NAS_Feb_2019
Tagged:

Best Answer

  • MijzelfMijzelf Posts: 513  Heroic Warrior Member
    Accepted Answer
    You should install package profile-hook . It should be installed at setup, but maybe the server was not accessible?

Answers

  • kempiudekempiude Posts: 6  Junior Member
    You need to check this two files:
    /opt/etc/init.d/S99ProfileHook
    /opt/etc/profile

    In the /opt/etc/profile file you should have a line:
    export PATH=/opt/bin:/opt/sbin:$PATH





  • alfaalfaalfaalfa Posts: 6  Junior Member
    Thanks kempiude for the prompt reply! 
    /opt/etc/profile contains this line. As for /opt/etc/init.d/S99ProfileHook, I have no such file. What should be a content of it? Could you paste yours? Many thanks!
  • alfaalfaalfaalfa Posts: 6  Junior Member
    edited February 7
    Thanks, Mijzelf!!! It turns out I was following an old tutorial and using your old repository. Placing a new repository in web_prefix file and reinstall solved this issue.
Sign In or Register to comment.