« Back to all recent discussions

NSA325: Trouble installing MetaRepository

proxyboxproxybox Posts: 6  Junior Member
edited January 11 in Questions

I read/researched as many posts around the net about my issue but since many forums have been discontinued, I'm having issues finding answers. I'd like to get SMB updated to Version 2.0 or 3.0 and read that I should install MetaRepository for this on my NSA325 V1.

Firmware: 4.81

First, I copied MetaRepository_20181001_arm_015.zpkg into my \\nsa325\admin\zy-pkgs folder. Then went to web interface and click Retrieve List from Internet under Package tab. However, the factory list only shows. I never get the Meta install prompt

Next, I created a web_prefix file with the URL for the files but still no luck

I then read about getting root access. I was able to telnet with root & my admin password, lookup my NsaRescueAngel password (/sbin/makekey) and then going to http://<ip-of-nas>/r<entered my code>,/adv,/cgi-bin/remote_help-cgi?type=backdoor, then logging into NsaRescueAngel with that password. I then went back to the web interface and tried again. Still no luck.

What am I missing? Also, once I do get Meta installed what package should I install to get SMB updated? 


Thanks guys,


Jon

#NAS_Jan_2019

Best Answer

  • MijzelfMijzelf Posts: 707  Heroic Warrior Member
    Accepted Answer
    Oops! Sorry, the name is zyxel-samba-replacement.
«1

Answers

  • MijzelfMijzelf Posts: 707  Heroic Warrior Member
    Here are installation instructions:

    To install samba 3.6.25 you have to install Entware-ng, and in Entware-ng zyxel-samba-replacement


  • proxyboxproxybox Posts: 6  Junior Member
    edited January 11

    Thanks Mijzelf!!! I guess my link was not correct in the web_prefix file from prior instructions. It installed now but when I go to the management page, it's blank and the page keeps on trying to refresh.


    Update: Never mind. I tried Chrome and it worked flawlessly. Previously I was using IE.

    Thanks so much for all you do.

  • proxyboxproxybox Posts: 6  Junior Member

    Last hurdle... I think. :) 

    I got as far as installing entware-ng. I don't see zyxel-samba-replacement in the packages. All I see are in the screenshot attached when searching for samba

    Should I just install the server package?

    Thanks again.


  • MijzelfMijzelf Posts: 707  Heroic Warrior Member
    The repo in the screenshot is the 'official' repo only.

    To get the zyxel-samba-replacement package, you should login over ssh/telnet (rad the 'Shell access' chapter).
    More here:


  • proxyboxproxybox Posts: 6  Junior Member
    edited January 13
    Another step closer but with a glitch. I followed the directions but got this error. I did an LS command but no files showed up. I also did a cd opt but it wouldn't allow me to change directories. I'm a newb. Thanks Mijzelf

  • proxyboxproxybox Posts: 6  Junior Member
    No apologies you're doing me the favor. Thanks for everything and responding. Getting really close but got the last error.


  • MijzelfMijzelf Posts: 707  Heroic Warrior Member
    That's a harmless one-time bug. On next start it's gone.


  • proxyboxproxybox Posts: 6  Junior Member
    Repped! Everything works great and now I don't have to enable the insecure SMB 1.0. 

    For those trying this too, go into Shares and for each one you setup, unclick the use Recycle Bin. You won't be able to access the shares on windows unless you remove that check box.
  • AscomaAscoma Posts: 2  Junior Member
    Where and how can I add more repos (with the zyxel-samba-replacement)

    I've already installed entware-ng. I don't find the package in the UI (like the screenshot above), but '# opkg list' prints: 'zyxel-samba-replacement - 3.6.25 - Replace the ancient samba server of a ZyXEL nas by the more modern Entware-ng one.'

    As a pessimistic software dev ... how does the replacement work? From some comments I *think* it will stop the builtin smbd and starts the one from /opt

    Will the web-UI to configure still work?
    Any known issues (expect the recycler bin)?
  • MijzelfMijzelf Posts: 707  Heroic Warrior Member
    edited April 4
    Where and how can I add more repos (with the zyxel-samba-replacement)
    As a pessimistic software dev ... how does the replacement work?
    Will the web-UI to configure still work?
    Yes. It writes to /etc/samba/smb.conf, which is included in the 'replacement conf'.





  • AscomaAscoma Posts: 2  Junior Member
    Works great!

    Just had some fun with my old NSA325. I compiled a version of minio.io s3 server for this zyxel.
  • StefanAMStefanAM Posts: 4  Junior Member
    edited August 14
    Hi Mijzelf! I tried to follow the tutorial but I ended up in this situation. Any hints please?
  • MijzelfMijzelf Posts: 707  Heroic Warrior Member
    Read the page about 'Entware-ng & FFP coexisting'.
  • StefanAMStefanAM Posts: 4  Junior Member
    edited August 15
    Hi again! I don't know what I have to do. Please be more specific.

    == Welcome at FFP version 0.7/arm, running on NSA325v2 NSA325-v2, firmware V4.81(AALS.1) ==

    [email protected]:~# echo $PATH

    /ffp/opt/java/jre/bin:/ffp/opt/java/jre/bin:/ffp/sbin:/usr/sbin:/sbin:/ffp/bin:/usr/bin:/bin

Sign In or Register to comment.