« Back to all recent discussions

NSA310s predefined shares without disk value

klcko001klcko001 Posts: 7  Junior Member
edited November 2018 in Questions
Hello, I am not able to assigned predefined shares ( like "video")to a disk volume on ma NSA320s. I have tried factory reset, reinstall, ... nothing helps .... Because of this I can not copy any file to predefined shares. Predefined share path is without volume name. I can only create my own- user defined shares, but they are not stable enough. When NSA is restarted, user-defined shares changed their permission to private, and folders are not visible anymore. I have attached some pictures , Can you please help me ?  

#NAS_Oct_2018
Tagged:

Best Answer

  • MijzelfMijzelf Posts: 1,073  Heroic Warrior Member
    edited October 2018 Accepted Answer
    drwxrwxrwx    1 root     root          2048 Jul 29  2013 sysvol
    That's your problem. It's a directory, while it should be a symlink.

    So execute
    su

Answers

  • IjnrsiIjnrsi Posts: 254  Advanced Warrior Member
    Hi, 
    Is the HDD brand new?
    If yes, then I suggest you to recreate the volume and do again reset, because it seems the configuration is not matched your current HDD. 
     
  • klcko001klcko001 Posts: 7  Junior Member
    Helo, thank you for your answer. HDD is brand new / i have replaced the old broken one.I have tried: delete volume, recreate volume, run install again, .... but no succes. Does anybody have a hint fir me? Thank you.
  • MijzelfMijzelf Posts: 1,073  Heroic Warrior Member
    Do you have shell access? You can use the Telnet backdoor for that. Then execute
    ls -l /etc/zyxel/storage/
    It should show something like
    [email protected]:/$ ls -l /etc/zyxel/storage/
    Have a look at the symlink sysvol, which should point to your data volume. In my case this is /i-data/38aa86ff. In your case it will be something else, and have a look if that volume exists:
    ls /i-data/


  • klcko001klcko001 Posts: 7  Junior Member
    -rw-rw-rw-    1 root     root             0 Oct 17 19:06 extuuid.table
    -rw-rw-rw-    1 root     root             0 Oct 31 20:05 mduuid.table
    drwxrwxrwx    1 root     root          2048 Jul 29  2013 sysvol
    -rw-rw-rw-    1 root     root             0 Dec 31  2016 usbcopy.table
    -rw-rw-rw-    1 root     root             0 Dec 31  2016 usbzync.table
    ~ $

  • klcko001klcko001 Posts: 7  Junior Member
    /etc/zyxel/storage/sysvol $ ls /i-data/
    abd50cdc  md0
    /etc/zyxel/storage/sysvol $
  • klcko001klcko001 Posts: 7  Junior Member
    /etc/zyxel/storage/sysvol $ su

    BusyBox v1.17.2 (2017-06-08 10:52:17 CST) built-in shell (ash)
    Enter 'help' for a list of built-in commands.

    ~ # echo "Volume1" >/i-data/sysvol/.system/name_label
    sh: can't create /i-data/sysvol/.system/name_label: nonexistent directory
    ~ #
  • klcko001klcko001 Posts: 7  Junior Member
    /etc/zyxel/storage/sysvol $ ls
    admin   music   photo   public  video
    /etc/zyxel/storage/sysvol $

Sign In or Register to comment.