« Back to all recent discussions

VMG3925-B10 (BUG) Obtain DNS Automatically is grayed out when Static IP Address option is selected.

ZyxelerZyxeler Posts: 3  Junior Member
edited June 2018 in Discussions
When creating a PVC, if I choose to enter my WAN IP manually, web interface forces me to also enter dns addresses manually. These two are completely different settings and should be independent of each other. This is the first router I've ever encountered this situation.
Edit: I forgot to mention that my ISP is using PPPoE as encapsulation method.

Device: VMG3925-B10
Firmware Version: V5.13(AAVF.11)C0   (Latest)

Reproduction steps> Network Setting>Broadband>Add New WAN Interface> Select Static IP Address

#CPE_June
Tagged:

Comments

  • AAAALAAAAL Posts: 125  Warrior Member
    edited June 2018

    Hi Zyxeler,

    If we select the IP address in “Static IP Address”, VMG3925-B10B will use that static IP address directly. It means VMG3925-B10B cannot obtain any DNS information through internet discovery packets. I think this is an inseparable setting, just like if we want to set the IP address in our PC by manually, we should also enter the DNS server address on our own. The setting “Obtain DNS server address automatically” will also be grayed out in our PC.

    I think if your ISP provided the static IP address for you, you should also ask them to provide the DNS address. Or your ISP is provided the PPPoE username and password ?

    You can check VMG3925-B10B user guide Chapter 6 for the Broadband WAN Interface setting which is more clearly explained in this.

    https://www.zyxel.com/us/en/support/DownloadLandingSR.shtml?c=us&l=en&kbid=M-02409&md=VMG3925-B10B


  • ZyxelerZyxeler Posts: 3  Junior Member
    Hello AAAAL and thank you for your reply.

    My ISP provides me two static IPs to choose from and a PPPoE username and a password.
    Unlike LAN settings on our PCs, routers obtain DNS Adresses from ISPs during PPP negotiation (ppp ipcp dns request). If we set the modem/router in bridge mode and configure a PPP connection on PC, it too should be able to obtain DNS info from ISP regardless of static IP option.

    I've read the page you referred me to and it says:
    'If your ISP assigns you a static WAN IP address, they should also assign you the subnet mask and DNS server IP address(es)'

    That might be true for IPoE connection, but for PPPoE I only need to know my IP addresses. My previous router ASUS for example, was able to obtain DNS info automatically when I manually entered my static IP.

    The reason I'm sure it must be a bug in the GUI is this:

    I entered Google DNS addresses (8.8.x.x) on WAN Interface page, saved and reboot. (still using Static IP option)
    I checked Logs and even though router now uses Google DNS it still shows my ISP's DNS adresses obtained during PPP negotiation:

  • AAAALAAAAL Posts: 125  Warrior Member

    Hi Zyxeler,

    Thanks your update for this. So, GUI will change your DNS IP address from that static IP (8.8.x.x) to your ISP's DNS IP ? Or this is just show in the log, the GUI state page is still show the static DNS IP you entered ? Want to confirm if all the internet services is working fine or not in this situation ?

    I get the point you met, will conduct more in-depth research on this issue.

  • ZyxelerZyxeler Posts: 3  Junior Member
    Hello AAAAL,

    DNS addresses (8.8.x.x) I manually entered on WAN Interface page stayed the same and are in use. I know that because my ISP's DNS would redirect/block some pages.

    Log just shows that router is able to obtain ISP DNS info regardless of Static WAN IP setting, but due to a restriction in the GUI, is unable to apply them automatically.

    Everything is working fine, I know it's a small issue, I just wanted to report this particular oversight. Thanks again for your help.
Sign In or Register to comment.